标签:wsl (1)

全网首发如何把Pycharm远程解释器设置为WSL2 CentOS里面的python

全网首发如何把Pycharm远程解释器设置为WSL2 CentOS里面的python

背景

最近在Windows下面运行一个类似下面的脚本时遇到了一些问题,
import os
from config import request_params
for i in request_params['params']:
    os.system("python main.py" + "-i " + i)
是这样的,我的win10上装了两个python解释器,一个是用python官方提供的exe装的python3.7,一个是用pyenv-win装的2.7.8,然后执行了pyenv global 2.7.8,但是好像没什么卵用,命令行输入python仍然进的是3.7的交互式环境,

紧接着我们再来说说上面这个脚本,上面os.system()调用的那个main.py是主要执行的脚本,只兼容python2,问题出在哪呢,系统只会用python官方提供的exe装的python3.7来执行我这个main.py,那我这个main.py肯定要报错呀,

当时各种折腾都搞不定 … … 阅读更多